JD Fanatic Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter · #1 · (Edited)
Picked this thing up back in March of 2017 for $100.It sat buried in my garage until about a month ago. When I bought it the guy said it hasn’t ran in about 10 years. He said it needed a coil and a few other things. It came with a new coil,gas cap,air filter. First thing I did was remove side covers,hood, grill and grill support. Pulled carb, clean it put the new gaskets on and reinstalled carb. Had to make a trip to my local mower shop to get a breather tube, and some fuel line.This one was in bad shape. Replaced tube and fuel line from fuel pump to carb,and reinstalled air cleaner covers. Added some fuel to see if it’ll start. Cranked over but no spark. Cleaned points and still nothing. Replaced condenser and solved that problem. Cranked it over for a while and it fired up. Reset the carb and shut it down. Noticed the fuel tank was leaking from the nipple. Tried to seal it up but nothing I tried worked. Did a little research and found some grommets that one the fuel valve is installed it seals. Went to the mower shop and got the PCs I needed. Cut the nipple off the plastic tank. Drilled the hole out to .500”. Installed grommet and shut off valve and just like that it’s fixed.
5FD649F1-DC0B-4F4F-A13E-68E51A6A2A80.jpeg
E829DCCD-BDEC-4C00-8F4D-F1A739D22BB7.jpeg
66B8C6D5-C12B-4B92-876B-F7A8C8E31464.jpeg
 

·
Registered
Joined
·
225 Posts
Discussion Starter · #2 ·
Installed the sleeve hitch lift rod and linkages last week. What a pain in the ass. To my surprise this thing had a helper spring already mounted. That had to come off in order to mount lift because the back lift stop hit the helper spring base. Had to remove lift stops and cut rear stop so the spring had clearance. And would go the whole way down in order to get pin out of lifting mechanism to install rear lift rod.Had to ask Don if he had issues installing any. He gave me some pointers to help along the way. After a lot of aggravation I got it installed.
A574D347-549B-4D55-9636-F98F62064F87.jpeg
 

·
Registered
Joined
·
225 Posts
Discussion Starter · #11 ·
The 214 did very well. Had some issues with getting the plow set up. turns out i think it was the area i was trying to set it up in.went to another part and it worked fine.Had some issues with the safety switch on the shifter that i figured out friday night.That seats gotta go. A little hard on the backside.
 
1 - 11 of 11 Posts
Top